Shockbyte - [Shockbyte Panel] Email Provider Outage – Incident details

[Shockbyte Panel] Email Provider Outage

Resolved
Degraded performance
Started 12 days agoLasted about 3 hours

Affected

Billing System (shockbyte.com/billing)

Degraded performance from 7:30 AM to 10:11 AM

Control Panel (panel.shockbyte.com)

Degraded performance from 7:30 AM to 10:11 AM

Updates
  • Resolved
    Resolved

    Our upstream service provider's outage is now resolved, and emails are delivering as expected.

  • Identified
    Identified

    We're aware of an upstream outage affecting our email deliverability, which is impacting service emails and password reset emails.