The maintenance is now complete, and no further disruption is expected. If you are still experiencing issues, please reach out to our support team.
Update
March 25, 2025 at 9:00 AM
In progress
March 25, 2025 at 9:00 AM
Maintenance is now in progress
In progress
March 25, 2025 at 9:00 AM
In progress
March 25, 2025 at 9:00 AM
Maintenance is now in progress
Planned
March 25, 2025 at 9:00 AM
Planned
March 25, 2025 at 9:00 AM
On Tuesday, 25th March at 9am UTC, we will be conducting a network maintenance to update our internal DNS resolvers. This upgrade will be rolled out gradually, and we will monitor the situation closely for any anomalies.
We do not expect any service interruption during this window, but it is possible that some servers may experience issues contacting authentication servers, or downloading updates for a few minutes during the window.