Scheduled for November 26, 2025 at 12:00 AM – 7:00 AM
Affects
Game Servers: Europe
Under maintenance from 12:00 AM to 7:00 AM
Amsterdam, NL
Under maintenance from 12:00 AM to 7:00 AM
Updates
Completed
November 26, 2025 at 7:00 AM
Completed
November 26, 2025 at 7:00 AM
Maintenance has completed successfully
In progress
November 26, 2025 at 12:00 AM
In progress
November 26, 2025 at 12:00 AM
Maintenance is now in progress
Planned
November 26, 2025 at 12:00 AM
Planned
November 26, 2025 at 12:00 AM
We will be performing scheduled network maintenance affecting a section of our infrastructure in Amsterdam, Netherlands.
This maintenance is part of our ongoing efforts to ensure optimal performance and reliability. No service disruption is expected during this window; however, we are sharing this notice out of an abundance of caution.
In the unlikely event of an interruption, you may experience temporary issues such as the control panel appearing unresponsive or displaying a “Server connection lost” message for up to 15 minutes at a time.
We appreciate your understanding and patience as we continue to improve our network. Thank you for your support.