The scheduled maintenance has now been completed, and affected customers will be receiving emails with their new server IPs shortly.
Posted Sep 14, 2023 - 16:57 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 14, 2023 - 08:01 UTC
Scheduled
(Not all servers will be affected - scroll down to find out if your server is affected by this maintenance)
We occasionally perform hardware upgrades to ensure we are always providing the best and latest hardware for our customers.
On Thursday 14th September, beginning at 8am UTC, we will be upgrading the hardware of many servers in our North America and Europe locations. We expect a downtime of up to 3 hours during the switchover period, however the actual length will vary (it could be shorter or longer).
We have blocked out 8 hours for this maintenance, however we do not expect servers to be affected for the entire period.
The upgrade will be performed as a rolling upgrade, which means affected servers will be upgraded at some point during the maintenance period - not necessarily at the beginning.
Rest assured that we are making every effort to minimise impact to customers.
Your server ID, displayed on the Multicraft Control Panel, contains your node ID after the hyphen. An example would be 12345-23, where 23 is the node ID. You can check whether your server is affected by viewing the list of affected nodes below.
Affected servers could be subject to an IP change, in which case you will receive an email with your updated IP address.